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Introduction to MS Publisher

Creating a Brochure Using Publisher 2003

This tutorial was designed for students who have a basic understanding of and
experience using the windows platform. The goal of this handout is to acquaint
you with the software and allow you to develop the skills you will need to
successfully use Publisher 2003 to create, layout and edit a brochure for
publication.

Publisher 2003 is a WYSIWYG (What You See Is What You Get) editor which
means that you will see what your publication looks like as you are creating it and
what it will look like once it is published.

After completing this lesson, you should be able to:

How to create a one-page publication using design templates
How to edit content of an existing publication

How to insert and format text

How to handle text overflow

How to insert and format pictures/images/clipart

How to create a blank publication

How to print the publication
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Creating a New Publication

Publisher can be used to create a variety of publications. The first step is to determine the type of
publication you will be creating. Before we begin designing the document, let’s identify key
elements in the Publisher environment.

Standard Toolbar Menu Bar Title Bar
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Title Bar

Displays the name of the Publisher publication and the application.

Menu Bar

Provides access to Publisher’s feature and dialog boxes.

Standard Toolbar

Contains buttons that provide quick access to some of the most frequently used
commands.

Formatting Toolbar

Contains buttons that provide quick access to some of the most frequently used
formatting commands.

Connect Text Boxes
Toolbar

Contains buttons for linking and unlinking text boxes.

Task Pane

Provides commonly used commands in a window. Its location and small size
enables you to use these commands while still working on your publication.
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Using Design Templates

o Mew Publication
1. Select Publications for

Print from the task pane_——m——

on the left side of the

screen. syew from a design

L BB PUblications Far Prink
Quick, Publications

2. Select the type of
publication — brochures.

advertisements
Award Certificates
3. Scroll through the Banners
categories of brochures
Brochures

and select a design set.

L @ Fublications For Prink

»

Mew from a design

» ‘Wehb Sites and E-mail

e Design Sets

# Blank Publications

4. Use the Brochure options panel to customize your publication.

a. Choose the number of columns.
b. Choose page size

a. Choose your address options.
b. Choose form type if desired.

5. Go to File>Save and save your publication.

** Note: The same procedures can be followed to create a newsletter
or other type of publication. **

Blocks Informational Brochure

< Brochure Options v X

ﬁ Brochure Options
Publication Designs

B2 Calar Schemes

A Font Schemes

Page size
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Include

Form
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=
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Sign-up form
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Customizing your brochure

Now that you've created the basic brochure layout, you can drop in headlines, articles, and clip
art to customize your brochure.

1. To customize your brochure, zoom in on the publication in one of the following ways:
« Click the Zoom box next to the plus and minus signs and then select a magnification

6.

from the list.
< Press F9.

Click on page 2 (bottom left of publication work area).
Click the placeholder text "Main Inside Heading" and type the main
heading or title for your brochure (e.g., Student Technology Center).

—» [1]2]

AutoFit is activated, so the text gets smaller as you type to fit in the text box.
Click the placeholder text "Secondary Heading" and type in the title for the next section of

information.

r-a'ﬁ Mail Fr

Continue clicking placeholder text and typing in your information. When entering your column
text, you may type directly into the text boxes provided or you may copy text from another
program such as Word. Each column is called a story. A story may take up only one frame

or it may take up several, linked frames.
Go to File>Save to save the work you have done so far.

To insert text from another program

You can type your brochure text in another program (such as Word, WordPerfect, or email) and
copy it into Publisher. When using another program to type your brochure text, do not do any
special formatting such as bullets, special fonts or margins.

1. Select the text in the program and choose the Copy feature
(in Word, this is Edit>Copy or Ctrl C).

2. Go to your publication window and select the column where
you wish to insert text. Go to Edit>Paste. The text should
appear in your Publisher column.

OR

3. Choose Insert from the Menu Bar and select Text File -
4. You may find that the text is too long for the column you m

selected. Publisher will ask you if you would like to use
AutoFlow or not. If you want Publisher to automatically create
columns to fit your text, then click Yes. If you want to place
the columns yourself (i.e., if you want to continue a story from
page one to page three), then click No.

Connecting text frames

Publisher allows you to type or insert text into one frame, continue it in another frame, and finish it
in still another frame.

1. To connect text frames, type or insert text into the first frame.

b - Microsoft Publisher - Print Public]

Wiew | Insert | Format  Tools Table  Apre

[ |

-
b

i | Page... Chrl+Shift+M
_| ¥ Page Mumbers. ..
Date and Time. ..
re Opt|
' Symbal...
(58| Design Gallery Cbject. ..
Ricture p [
[ TtextFie... |

t Schen

Schem

e

¥

2. Once the text reaches the end of the frame, any remaining text will go into the overflow

=3

3. To connect the overflow text to another frame, click Connect Text Frames. 2 [}}'

Your cursor will change to a pitcher.
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4. Click the frame where you wish to “pour” your text. The overflow text will “pour” into the

new frame. When you are finished, you will see the Go To Next Frame icon
which allows you to jump from one connected frame to the next.
5. Since the frames are connected, the length of the columns (or frames) are also
connected. If you lengthen the first frame of the column, the second frame will shorten.
If you shorten the first frame of the column, the second frame will lengthen to

accommodate the overflow text.

Inserting pictures and clip art

To Replace Design Object Placeholders:

Replacing a clipart image or photo in a picture frame: g " | Cut i
 Captim desendi (29 o o
1. Sglect thg image you WiSh. to change.' .:M ephiz i paste P

2. Click the image again to display the Picture N . Delete Object
Toolbar. = : it
3. Right click on the image and choose more abay | SHESSFCIE pices |

Change Picture/From File or other option——ﬂm‘; """ -

éﬁons.

®recommended for

ilengthy or complex ques-

Hide Picture Toolbar

Clip Art...

. Change Ficture 3 ||L3_—|
To insert a picture: ER":“]W L - v | ] From Fie..

1. First create a picture frame. Go to the 1, Format Picture. . @GP From Scanner or Camera,..
Objects toolbar, click Picture Frame. iFaculty memb — R Graphics Manager...
Position the mouse pointer and click where itechnelogfFE} -
you want one corner of the frame to appear, hold down the mouse button while you drag
the mouse diagonally until the frame is the size you want, and release the mouse button.

OR
If the frame already exists, click it.

2. Goto Insert>Picture>From File.

3. Click the name of the picture file you want to add. Note: You may need to browse to find
the drive or folder your picture is stored in.

4. Click Insert.

To insert clip art:

Create a Clip Gallery frame using the Objects toolbar. If the frame already exists,

1.
double-click it. The Clip Art Gallery window appears.
2. Click the tab for the type of clip you want.
3. Click the category you want.
4,

Scroll through the category, click the clip you want, and then click Insert clip.

The clip is inserted in your publication. If the Clip Gallery is covering your publication,

click outside the Clip Gallery window.
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Creating a Blank Brochure

You may find that none of the pre-made designs match the style or format you are looking for.
Publisher gives you the option to start a blank publication and add design elements to create a

publication to meet your specifications.
I Publication2 - Microsoft Publisher - Pri

TO Cl‘eate a blank brOChure: v File Edit Miew Insert  Format  Tools T
1. Choose File/New from the Main Menu and then HRNr=A™ RENTE NN« N EEN

select Blank Publications. P 4 | | -
2. Select the publication type = |

from the design gallery Full Page’ : New Publication T X
3. Next select File/Page Setup and -

New from a design

select the Landscape radio button
for orientation.

» Publications For Print
» Web Sites and E-mail
- Design Sets

Using the Rule Guides: e
Ruler guides allow you to align page elements properly N Full Page
and place object precisely on a page. These guides are s i
not displayed by default; when they are turned on they are o

for display purposes only and will not print.

To display ruler guides:
1. Choose Arrange/Ruler Guides/Add Vertical Ruler Guide
2. Repeat for Horizontal Ruler Guide

Using Margin Guides:

All text added to your brochure must be inserted into a text box. Margin guides are non-printing
lines that are used to define the margins on a page. Margins for a blank print publication are set
a to one inch for left, right, top and bottom by default. You may need to override the default
margin guides based on your publication needs.

To change margin guides:

1. Choose Arrange/Layout Guides

2. Setthe margins as desired Layout Guides
. . Margin Guides Prewview
Using Column Guides:
. 1 n
Columns and Margin Guides make up the most Left: @
important part of the underlying layout grid. _ "
; X ) . - Right: 1
Setting up columns will assist you in to divide
your brochure in equal columns for placement of ) lil "
text boxes and graphics. Tap: @
To display column guides: Battom: |1 g
3. Choose Arrange/Layout Guides 4 cid
4. Enter the number of columns for your e iz
brochure in the Columns box under
. . e > e
Grid Guides. Columns @
[ Creats Twn
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Wrapping text around a picture:

b Seeamepoe et 00 e - x
| n@m.molmm#fﬁ%@'@
2. On the picture toolbar select —
the text wrapping button or | Square |
right click on the picture and Tight
choose Format Picture and
select the Layout tab and Through
choose the desired layout. Top and Eotkam
Mone
Printing Brochures: 5] Edlit Wirap Points

The 3-panel brochures are designed to print in Landscape mode (sideways across the length) on
a standard 8 1/2" by 11" piece of paper. Standard settings is 1/4" margins all the way around.

To Print your Brochure:

From the main menu click File/Open and select PRINT. Click on the properties box to select the
paper type and print quality - Best, Normal or Draft.

Depending on how your printer is set up, print - page 1-1 then place the page back into the paper
tray to print side 2-2.

Tip: Print your trial copy in DRAFT mode to save unnecessary ink wastage.

Your brochure is now ready to fold and give to your potential customers or clients.

Visit: http://office.microsoft.com/en-us/assistance/HP030746221033.aspx for
additional commercial printing information.

Checking your spelling

1. If you misspell a word or Publisher 2000 does not recognize it, a red wavy line appears
directly beneath the word on the screen.

2. Right-click the underlined text to see suggested options.

OR

3. Goto Tools>Spelling>Check Spelling. The Spell Checker only checks one story at a time.
Once you have finished spell checking a story, Publisher will ask you if you want to check all
stories.

4. Click OK to continue checking spelling. The Check Spelling dialog box appears when a
misspelled word is found. You can change, ignore, or add the word to the dictionary.

5. If a misspelled word is not recognized (no spelling suggestion), you can right-click on the
word and select Check Spelling. Then type the word in the Change To field and click Change.
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Getting more help
There are many places you can go to get help.

In Publisher:
To get help in Publisher, go to Help>Microsoft Publisher Help or press the F1
key.

On Campus:
Call or drop by the Student Technology Center and get help from a tutor. The
STC is located in Z-214. The phone number is 964-2299.

Online:
You can also find tutorials, tips and design advice here:

http://office.microsoft.com/en-us/assistance/CH790018091033.aspx
http://www.bcschools.net/staff/PublisherHelp.htm
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